관리 메뉴

엔지니어스 - Engineeus

[Ubuntu] pip3 버전 문제 해결하기 본문

Autonomous Tech./Error (Windows & Ubuntu)

[Ubuntu] pip3 버전 문제 해결하기

Engineeus 2020. 1. 28. 15:20
728x90

자꾸 아래와 같은 문제가 뜬다.. pip 사용 시 왠만하면 sudo 사용 하지 말라고 했는데 어쩔까 검색 하다 찾았습니다.

WARNING: You are using pip version 19.2.1, however version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

 

해결책

$ sudo apt-get -y install python3-pip
$ sudo apt-get update
$ curl "https://bootstrap.pypa.io/get-pip.py" -o "get-pip.py"
$ python3 get-pip.py

출처

https://nagy.tistory.com/10

 

pip3 install on Ubuntu 16.04.4 LTS

여태 ARTIK 710 - fedora 에서 작업을 주로 해왔는데 점차적으로 os를 ubuntu로 바꿔가는 중 710 - ubuntu에서 작업하는 와중에 전에는 생각지도 못했던(?) pip3의 설치가 제대로 안되는 문제 발생 <발생한 에러>..

nagy.tistory.com

 

0 Comments
댓글쓰기 폼